Microsoft.International.Converters.PinYinConverter命名空间

Simplified Chinese Pin-Yin Conversion Library
Microsoft.International.Converters.PinYinConverter命名空间
命名空间 > Microsoft.International.Converters.PinYinConverter
Microsoft.International.Converters.PinYinConverter 命名空间包含了拼音和笔画转换工具的类。

语法
C# Visual Basic Managed C++
namespace Microsoft.International.Converters.PinYinConverter
Namespace Microsoft.International.Converters.PinYinConverter
namespace Microsoft.International.Converters.PinYinConverter
类型
所有类型 类 结构 接口 枚举 委托
图标 | 名称 | 描述
公有类 | ChineseChar | 封装了简体中文的读音和笔画等基本信息。


ChineseChar类

ChineseChar类
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar
封装了简体中文的读音和笔画等基本信息。
语法
C# Visual Basic Managed C++
public class ChineseChar
Public Class ChineseChar
public ref class ChineseChar
成员
所有成员 | 构造函数 | 方法 | 属性 | 字段 | 事件
公有的(Public) 受保护的(Protected) |  | 实例(Instance) 静态(Static) |  | 声明(Declared) 继承(Inherited)
图标 | 成员 | 描述
 | ChineseCharNew(Char) | ChineseChar类的构造函数。
 | ChineseCharacter | 获取这个汉字字符。
 | CompareStrokeNumber(Char) | 将给出的字符和实例字符的笔画数进行比较。
 | GetCharCount(Int16) | 检索具有指定笔画数的字符个数。
 | GetChars(String) | 获取给定拼音的所有同音字。
 | GetChars(Int16) | 检索具有指定笔画数的所有字符串。
 | GetHomophoneCount(String) | 检索具有指定拼音的字符数。
 | GetStrokeNumber(Char) | 检索指定字符的笔画数。
 | HasSound(String) | 识别字符是否有指定的读音。
 | IsHomophone(Char) | 识别给出的字符是否是实例字符的同音字。
 | IsHomophone(Char, Char) | 识别给出的两个字符是否是同音字。
 | IsPolyphone | 获取这个字符是否是多音字。
 | IsValidChar(Char) | 识别给出的字符串是否是一个有效的汉字字符。
 | IsValidPinyin(String) | 识别给出的拼音是否是一个有效的拼音字符串。
 | IsValidStrokeNumber(Int16) | 识别给出的笔画数是否是一个有效的笔画数。
 | PinyinCount | 获取这个字符的拼音个数。
 | Pinyins | 获取这个字符的拼音。
 | StrokeNumber | 获取这个字符的笔画数。
实例
以下代码演示了返回给出字符的笔划数。
拷贝C#
using System;
using System.Collections.Generic;
using System.Text;
using Microsoft.International.Converters.PinYinConverter;

namespace Example_CS
{
    class Program
    {
        static void Main(string[] args)
        {
            ChineseChar chineseChar = new ChineseChar('微');
            Console.WriteLine("Stroke number of 微 in Chinese is {0}.", chineseChar.StrokeNumber);
            Console.WriteLine("{0} characters' pinyin is \"wei1\".", ChineseChar.GetHomophoneCount("wei1"));
            if(ChineseChar.IsHomophone('微', '薇'))
            {
                Console.WriteLine("微 and 薇 have the same pinyin.");
            }
            else
            {
                Console.WriteLine("微 and 薇 have different pinyins.");
            }
        }
    }
}

// This code produces the following output:
//
// Stroke number of 微 in Chinese is 13.
// 37 characters' pinyin is "wei1".
// 微 and 薇 have the same pinyin.
拷贝VB.NET
Imports Microsoft.International.Converters.PinYinConverter

Module Main
    Sub Main()

        Dim chineseChar = New ChineseChar("微")
        Console.WriteLine("stroke number of 微 in Chinese is {0}.", chineseChar.StrokeNumber)
        Console.WriteLine("{0} characters' pinyin is \'wei1\'.", chineseChar.GetHomophoneCount("wei1"))
        If (chineseChar.IsHomophone("微", "薇")) Then
            Console.WriteLine("微 and 薇 have the same pinyin.")
        End If

    End Sub

End Module

' This code produces the following output.

' stroke number of 微 in Chinese is 13.
' 37 characters' pinyin is 'wei1'.
' 微 and 薇 have the same pinyin.
'
拷贝C++
#include "stdafx.h"

using namespace System;
using namespace Microsoft::International::Converters::PinYinConverter;

int main(array<System::String ^> ^args)
{
    ChineseChar ^chineseChar1 = gcnew ChineseChar(L'微');
    Console::WriteLine("stroke number of 微 in Chinese is {0}.", chineseChar1->StrokeNumber);
    Console::WriteLine("{0} characters' pinyin is \"wei1\".", ChineseChar::GetHomophoneCount("wei1"));
    if(ChineseChar::IsHomophone(L'微', L'薇'))
    {
        Console::WriteLine("微 and 薇 have the same pinyin.");
    }
    else
    {
        Console::WriteLine("微 and 薇 have different pinyins.");
    }

    return 0;
}

// This code produces the following output:
//
// Stroke number of 微 in Chinese is 13.
// 37 characters' pinyin is "wei1".
// 微 and 薇 have the same pinyin.
继承层次
Object
ChineseChar

程序集： ChnCharInfo (模块： ChnCharInfo) 版本： 1.0.0.0


ChineseChar构造函数 (ch)

ChineseChar构造函数 (ch)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > ChineseCharNew(Char)
ChineseChar类的构造函数。
语法
C# Visual Basic Managed C++
public ChineseChar (
    char ch
)
Public Sub New ( _
    ch As Char _
)
public:
ChineseChar (
    wchar_t ch
)
参数
ch (Char)
指定的汉字字符。
备注
请参阅ChineseChar来查看使用ChineseChar的实例。
异常
异常 | 条件
NotSupportedException | 字符不在简体中文扩展字符集中。


ChineseCharacter属性

ChineseCharacter属性
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > ChineseCharacter
获取这个汉字字符。
语法
C# Visual Basic Managed C++
public char ChineseCharacter { get; }
Public ReadOnly Property ChineseCharacter As Char
public:
property wchar_t ChineseCharacter {
    wchar_t get ();
}
字段值
汉字字符。
备注
请参阅ChineseChar来查看使用ChineseChar的实例。


CompareStrokeNumber方法(ch)

CompareStrokeNumber方法(ch)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > CompareStrokeNumber(Char)
将给出的字符和实例字符的笔画数进行比较。
语法
C# Visual Basic Managed C++
public int CompareStrokeNumber (
    char ch
)
Public Function CompareStrokeNumber ( _
    ch As Char _
) As Integer
public:
int CompareStrokeNumber (
    wchar_t ch
)
参数
ch (Char)
显示给出的字符
返回值
说明比较操作的结果。 如果给出字符和实例字符的笔画数相同，返回值为 0。 如果实例字符比给出字符的笔画多，返回值为> 0。 如果实例字符比给出字符的笔画少，返回值为< 0。
备注


GetCharCount方法(strokeNumber)

GetCharCount方法(strokeNumber)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > GetCharCount(Int16)
检索具有指定笔画数的字符个数。
语法
C# Visual Basic Managed C++
public static short GetCharCount (
    short strokeNumber
)
Public Shared Function GetCharCount ( _
    strokeNumber As Short _
) As Short
public:
static short GetCharCount (
    short strokeNumber
)
参数
strokeNumber (Int16)
显示需要被识别的笔画数。
返回值
返回具有指定笔画数的字符数。 如果笔画数是无效值返回-1。
备注
请参阅ChineseChar来查看使用 ChineseChar的实例。


GetChars方法

GetChars方法
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > GetChars
成员
图标 | 成员 | 描述
 | GetChars(Int16) | 检索具有指定笔画数的所有字符串。
 | GetChars(String) | 获取给定拼音的所有同音字。


GetChars方法(strokeNumber)

GetChars方法(strokeNumber)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > GetChars(Int16)
检索具有指定笔画数的所有字符串。
语法
C# Visual Basic Managed C++
public static char[] GetChars (
    short strokeNumber
)
Public Shared Function GetChars ( _
    strokeNumber As Short _
) As Char()
public:
static array<wchar_t>^ GetChars (
    short strokeNumber
)
参数
strokeNumber (Int16)
指出需要被识别的笔画数。
返回值
返回具有指定笔画数的字符列表。 如果笔画数是无效值返回空。
备注


GetChars方法(pinyin)

GetChars方法(pinyin)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > GetChars(String)
获取给定拼音的所有同音字。
语法
C# Visual Basic Managed C++
public static char[] GetChars (
    string pinyin
)
Public Shared Function GetChars ( _
    pinyin As String _
) As Char()
public:
static array<wchar_t>^ GetChars (
    String^ pinyin
)
参数
pinyin (String)
指出读音。
返回值
返回具有相同的指定拼音的字符串列表。 如果拼音不是有效值则返回空。
备注
请参阅ChineseChar来查看使用ChineseChar的实例。
异常
异常 | 条件
ArgumentNullException | 拼音是一个空引用。


GetHomophoneCount方法(pinyin)

GetHomophoneCount方法(pinyin)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > GetHomophoneCount(String)
检索具有指定拼音的字符数。
语法
C# Visual Basic Managed C++
public static short GetHomophoneCount (
    string pinyin
)
Public Shared Function GetHomophoneCount ( _
    pinyin As String _
) As Short
public:
static short GetHomophoneCount (
    String^ pinyin
)
参数
pinyin (String)
显示需要被识别的拼音字符串。
返回值
返回具有指定拼音的字符数。 如果拼音不是有效值则返回-1。
备注
请参阅ChineseChar来查看使用ChineseChar的实例。
异常
异常 | 条件
ArgumentNullException | 拼音是一个空引用。


GetStrokeNumber方法(ch)

GetStrokeNumber方法(ch)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > GetStrokeNumber(Char)
检索指定字符的笔画数。
语法
C# Visual Basic Managed C++
public static short GetStrokeNumber (
    char ch
)
Public Shared Function GetStrokeNumber ( _
    ch As Char _
) As Short
public:
static short GetStrokeNumber (
    wchar_t ch
)
参数
ch (Char)
指出需要识别的字符。
返回值
返回指定字符的笔画数。 如果字符不是有效值则返回-1。
备注


HasSound方法(pinyin)

HasSound方法(pinyin)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > HasSound(String)
识别字符是否有指定的读音。
语法
C# Visual Basic Managed C++
public bool HasSound (
    string pinyin
)
Public Function HasSound ( _
    pinyin As String _
) As Boolean
public:
bool HasSound (
    String^ pinyin
)
参数
pinyin (String)
指定的需要被识别的拼音。
返回值
如果指定的拼音字符串在实例字符的拼音集合中则返回ture，否则返回false。
备注
请参阅ChineseChar来查看使用ChineseChar的实例。
异常
异常 | 条件
ArgumentNullException | 拼音是一个空引用。


IsHomophone方法

IsHomophone方法
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > IsHomophone
成员
图标 | 成员 | 描述
 | IsHomophone(Char) | 识别给出的字符是否是实例字符的同音字。
 | IsHomophone(Char, Char) | 识别给出的两个字符是否是同音字。


IsHomophone方法(ch)

IsHomophone方法(ch)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > IsHomophone(Char)
识别给出的字符是否是实例字符的同音字。
语法
C# Visual Basic Managed C++
public bool IsHomophone (
    char ch
)
Public Function IsHomophone ( _
    ch As Char _
) As Boolean
public:
bool IsHomophone (
    wchar_t ch
)
参数
ch (Char)
指出需要识别的字符。
返回值
如果给出的实例字符是同音字则返回ture，否则返回false。
备注


IsHomophone方法(ch1, ch2)

IsHomophone方法(ch1, ch2)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > IsHomophone(Char, Char)
识别给出的两个字符是否是同音字。
语法
C# Visual Basic Managed C++
public static bool IsHomophone (
    char ch1,
    char ch2
)
Public Shared Function IsHomophone ( _
    ch1 As Char, _
    ch2 As Char _
) As Boolean
public:
static bool IsHomophone (
    wchar_t ch1,
    wchar_t ch2
)
参数
ch1 (Char)
指出第一个字符
ch2 (Char)
指出第二个字符
返回值
如果给出的字符是同音字返回ture，否则返回false。
备注


IsPolyphone属性

IsPolyphone属性
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > IsPolyphone
获取这个字符是否是多音字。
语法
C# Visual Basic Managed C++
public bool IsPolyphone { get; }
Public ReadOnly Property IsPolyphone As Boolean
public:
property bool IsPolyphone {
    bool get ();
}
字段值
这个布尔型的字符是否是多音字。
备注


IsValidChar方法(ch)

IsValidChar方法(ch)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > IsValidChar(Char)
识别给出的字符串是否是一个有效的汉字字符。
语法
C# Visual Basic Managed C++
public static bool IsValidChar (
    char ch
)
Public Shared Function IsValidChar ( _
    ch As Char _
) As Boolean
public:
static bool IsValidChar (
    wchar_t ch
)
参数
ch (Char)
指出需要识别的字符。
返回值
如果指定的字符是一个有效的汉字字符则返回ture，否则返回false。
备注


IsValidPinyin方法(pinyin)

IsValidPinyin方法(pinyin)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > IsValidPinyin(String)
识别给出的拼音是否是一个有效的拼音字符串。
语法
C# Visual Basic Managed C++
public static bool IsValidPinyin (
    string pinyin
)
Public Shared Function IsValidPinyin ( _
    pinyin As String _
) As Boolean
public:
static bool IsValidPinyin (
    String^ pinyin
)
参数
pinyin (String)
指出需要识别的字符串。
返回值
如果指定的字符串是一个有效的拼音字符串则返回ture，否则返回false。
备注
请参阅ChineseChar来查看使用ChineseChar。
异常
异常 | 条件
ArgumentNullException | 拼音是一个空引用。


IsValidStrokeNumber方法(strokeNumber)

IsValidStrokeNumber方法(strokeNumber)
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > IsValidStrokeNumber(Int16)
识别给出的笔画数是否是一个有效的笔画数。
语法
C# Visual Basic Managed C++
public static bool IsValidStrokeNumber (
    short strokeNumber
)
Public Shared Function IsValidStrokeNumber ( _
    strokeNumber As Short _
) As Boolean
public:
static bool IsValidStrokeNumber (
    short strokeNumber
)
参数
strokeNumber (Int16)
指出需要识别的笔画数。
返回值
如果指定的笔画数是一个有效的笔画数则返回ture，否则返回false。
备注


PinyinCount属性

PinyinCount属性
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > PinyinCount
获取这个字符的拼音个数。
语法
C# Visual Basic Managed C++
public short PinyinCount { get; }
Public ReadOnly Property PinyinCount As Short
public:
property short PinyinCount {
    short get ();
}
字段值
这个字符的拼音数。
备注


Pinyins属性

Pinyins属性
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > Pinyins
获取这个字符的拼音。
语法
C# Visual Basic Managed C++
public ReadOnlyCollection<string> Pinyins { get; }
Public ReadOnly Property Pinyins As ReadOnlyCollection(Of String)
public:
property ReadOnlyCollection<String^>^ Pinyins {
    ReadOnlyCollection<String^>^ get ();
}
字段值
这个字符的拼音。
备注


StrokeNumber属性

StrokeNumber属性
命名空间 > Microsoft.International.Converters.PinYinConverter > ChineseChar > StrokeNumber
获取这个字符的笔画数。
语法
C# Visual Basic Managed C++
public short StrokeNumber { get; }
Public ReadOnly Property StrokeNumber As Short
public:
property short StrokeNumber {
    short get ();
}
字段值
这个字符的笔画数。
备注


命名空间

命名空间
命名空间
命名空间
命名空间 | 描述
Microsoft.International.Converters.PinYinConverter | Microsoft.International.Converters.PinYinConverter 命名空间包含了拼音和笔画转换工具的类。